# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b.+)(?=\1)"
test_str = ("...\n"
"bedeubedeu France The Provençal name for tripe\n"
"bee balmbee balm Bergamot\n"
"beechmastbeechmast Beech nut\n"
"beech nutbeech nut A small nut from the beech tree,\n\n"
"genus Fagus and Nothofagus, similar in\n"
"flavour to a hazelnut but not commonly used.\n"
"A flavoursome oil can be extracted from\n"
"them. Also called beechmast\n\n"
"beechwheatbeechwheat Buckwheat\n"
"beefbeef The meat of the animal known as a cow\n\n"
"(female) or bull (male) (NOTE: The Anglo-\n"
"saxon name ‘Ox’ is still used for some of what\n"
"were once the less desirable parts e.g. oxtail,\n"
"ox liver)\n\n"
"beef bourguignonnebeef bourguignonne See boeuf à la\n"
"bourguignonne\n"
"...")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.