$re = '/(?:\s|^)([\-+]?)(?:(")([^"]+)"|(\')([^\']+)\'|()(\S+))/i';
$str = 'dg "" -\'\' -\'korv asas\' "apa banan" +öapa+banan sdf +sdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);