re = /^(?!.*\.{2})[a-z0-9.]+$/mi
str = 'test.test.test.test
test.test..test...test
test..test.test.test
test..test..test.test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end