$re = '/^[^\/]+\/statistics\b(?:\/?[^\/]+)*\/?$/m';
$str = 'folder1/statistics123
folder1/statistics/test1/another_folder
folder1/statistics/test2
folder2/statistics
folder2/statistics/test1
folder2/statistics/test2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);