$re = '/\$.*?\$\K|\\\\\w+(?(?=\s)|\K)/s';
$str = 'Example of \\bad command. Example of \\good\\ command. And $x=\\math + y$.
Example of \\bad command. Example of \\good\\ command. And $x=\\math + y$.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);