$re = '/([a-z])(\1{2})/';
$str = 'pppllleaaaseee ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);