re = /<(?:.|\n)*?>/m
str = '<p>If you want me to give you a two-hour presentation, I am ready today. If you want only a five-minute speech, it will take me two weeks to prepare. <\\/p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end