$re = '/(\w\w) (\d{5})-(?:\d{4})/m';
$str = ' CA 95131-3059';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);