re = /(?<!\\){aaa}/
str = 'this is a test called \\\\{aaa} and this is a test called \\{aaa} '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end