re = /^(?=.{4,32}$)(?![_.-])(?!.*[_.]{2})[a-zA-Z0-9._-]+(?<![_.])$/
str = 'sadsd._dfds'
# Print the match result
str.match(re) do |match|
puts match.to_s
end