$re = '/(?=(\d+\D+\d+))./';
$str = '2abc3abc4abc5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);