$re = '/https?:\/\/vk\.com\/(([^\/].+)|(id([^\/]\d+)))/';
$str = 'http://vk.com/daager
http://vk.com/id123456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);