$re = '/[AD][0-9]{8,8}$/';
$str = 'AD12345678';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);