$re = '/^(?=.*a2)(?=.*b2)(?=.*c2)/';
$str = 'I c2 like a2! b2, b2, b2!.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);