$re = '/([a-zA-Z0-9öÖäÄüÜß]+\s){3}|([a-zA-Z0-9öÖäÄüÜß]+\s){1,2}/';
$str = 'Hello my name is Tom and i love playing football sex
1: Hello my name 2: is Tom and 3: i love playing 4: football';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);