re = /([a-zA-Z0-9öÖäÄüÜß]+\s){3}|([a-zA-Z0-9öÖäÄüÜß]+\s){1,2}/
str = 'Hello my name is Tom and i love playing football
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end