re = /^(?!.*unwanted.*).+[\r\n](expression2 expression3)/m
str = 'expression2 expression3 // Not Matched...
unwanted
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...
unwanted
expression2 expression3 // Not Matched...
sdgfkjsdöfkjsdöfkjsdf
expression2 expression3 // Matched...
unwanted sdasd
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...
string
expression2 expression3 // Not Matched...
unwanted
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end