using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\.?\d*万?-?\d*\.?\d*万?)元?/(?!套)";
string input = @"item 1:298元/套起
item 1:298元/m2起
item 1:298/m2起
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}