import Foundation
let pattern = #"^20([0-2][0-9])(\.(0[1-9]|1[012])(\.(0[1-9]|1[0-9]|2[0-9]|3[01]))?)?_[a-z]{1,18}((\-)?[a-z]{1,13})?((\.[a-z]{1})|(\.[a-z]{1,18}\.[a-z]{1}))?_(([a-z]{1,18}((\-)[a-z]{1,13})?)(\.[a-z]{1,18}){0,3})?_(m|w)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2012.11.09_mary-ann.ursula.k_san.luis.obispo_w
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}