$re = '/(?:\w+:)?\/\/[^\/]+([^?#]+)/';
$str = 'https://domain.com/part1/part2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);