use strict;
my $str = 'Strängnäs';
my $regex = qr/[^\000-~]/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";