re = /^(\d+')?(?:(?<=')\s*-\s*)?(\d+(?:\s*\d+\/\d+|\.\d+)?")$/
str = '111\' - 12.01"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end