using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&|([^&]*(?:&(?!amp;)[^&]*)*)";
string input = @"abc Ben & Jerry's foobar ssss sss sss &
sssss&sssss &
sssss&sssss &sssss
&sssss&
&&";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}