package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*_`)
var str = `GridView1__ctl2_chkOut`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}