import re
regex = re.compile(r"^\((?P<speciality>(?:[0-9x]+,?)*)(?=\))", flags=re.MULTILINE)
test_str = ("(7)Which of the following is LEAST to be considered as a risk factor for esophageal cancer?;\n\n"
"(8,13)30 year old woman with amenorrhea, low serum estrogen and high serum LH/FSH, the most likely diagnosis is:\n\n"
"First trimester spontaneous abortion (before 20 wk) is most commonly due to:\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")