$re = '/(?<=<p\sitemprop="description">).*?(?=<\/p>)/s';
$str = '<p itemprop="description"> DESCRIPTION HERE </p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);