re = /http:\/\/myServer:28020\/MyService\/ItemWebService\.json\?action=keywordSearch(?:&?[^=&]*=[^=&]*)*/
str = 'http://myServer:28020/MyService/ItemWebService.json?action=keywordSearch&username=StockOnHandPortlet&sessionId=2H7Rr9kCWPgIZfrxQiDHKp0&keywords=blue&itemStatus=A'
# Print the match result
str.match(re) do |match|
puts match.to_s
end