import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<HEADER>#EXTM3U|\\G(?!\\A))\\R\\K#EXTINF:(?<DURATION>-?\\d+\\.?\\d+),(?<TITLE>.+)?\\R(?<URI>\\S+)";
final String string = "#EXTM3U\n"
+ "#EXTINF:10.0,\n"
+ "media_w854021192_21533.ts\n"
+ "#EXTINF:10.0,\n"
+ "media_w854021192_21534.ts\n"
+ "#EXTINF:10.0,\n"
+ "media_w854021192_21535.ts";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}