const regex = /^(\d)\1{2}-(\d)\1{1}-(\d)\1{3}$|^(\d)\1{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d)\\1{2}-(\\d)\\1{1}-(\\d)\\1{3}$|^(\\d)\\1{8}$', 'gm')
const str = `888888888
123456789
888-88-8888
123-45-6789
111-22-3333
333-33-3333`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}