$re = '/[^\w\s]|(\D)(?=\1)/';
$str = 'p11ppppl';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;