$re = '~\.([^.]+)$~m';
$str = 'foobar
test.png
test.somethingelse.png
some.test.with.dots.GIF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);