using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<li>.*?<a href=""([^""]+)"".*?alt=""On Contact: ([^""]+)"".*?<p[^>]*>((?:(?!</p>).)+?)</p>.*?<p[^>]*>([^<]+)<";
string substitution = @"";
string input = @" <li><p style=""margin-bottom: 0in""><a href=""https://www.rt.com/shows/on-contact/550756-america-long-war-race/"">On
Contact: Race and America's long war </a>
</p>
<p style=""margin-bottom: 0in""><a href=""https://www.rt.com/shows/on-contact/550756-america-long-war-race/"">
<font color=""#000080"">
<img src=""rt.com-on_contact-220405-no_blurb_html_1dff87941f1c724a.jpg"" name=""Image1"" alt=""On Contact: Race and America's long war"" align=""bottom"" width=""280"" height=""157"" border=""1""/>
</font>
</a>
</p>
<p style=""margin-bottom: 0in"">On the show, Chris Hedges discusses
America's inner and outer wars and its nexus with capitalism and
empire with Professor of Social and Cultural Analysis and History at
New York University Nikhil Pal Singh. The internal violence in the
United...
</p>
<p style=""margin-bottom: 0in"">Feb 27, 2022 10:36</p>
<li><p style=""margin-bottom: 0in""><a href=""https://www.rt.com/shows/on-contact/550319-george-washington-genocidal-colonist/"">
<font color=""#000080"">
<img src=""rt.com-on_contact-220405-no_blurb_html_198feb67032166ff.png"" name=""Image3"" alt=""On Contact: George Washington and the legacy of white supremacy"" align=""bottom"" width=""280"" height=""157"" border=""1""/>
</font>
</a>
</p>
<p style=""margin-bottom: 0in""><strong><a href=""https://www.rt.com/shows/on-contact/550319-george-washington-genocidal-colonist/"">On
Contact: George Washington and the legacy of white supremacy </a></strong>
</p>
<p style=""margin-bottom: 0in"">On the show, Chris Hedges discusses
George Washington, the fallible human being and one of the principal
architects of the United States, with author Nathaniel Philbrick. As
America fractures into ideologically hostile camps, it colors how
we...
</p>
<p style=""margin-bottom: 0in"">Feb 25, 2022 09:09
</p>
<li>[...]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}