#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(?:(?!<li>).)*<li>.*?<a href="([^"]+)".*?alt="On Contact: ([^"]+)".*?<p[^>]*>((?:(?!</p>).)+?)</p>.*?<p[^>]*>([^<]+)<(?:(?!<li>).)*"
Local $sString = " <li><p style="margin-bottom: 0in"><a href="https://www.rt.com/shows/on-contact/550756-america-long-war-race/">On" & @CRLF & _
" Contact: Race and America's long war </a>" & @CRLF & _
" </p>" & @CRLF & _
" <p style="margin-bottom: 0in"><a href="https://www.rt.com/shows/on-contact/550756-america-long-war-race/">" & @CRLF & _
" <font color="#000080">" & @CRLF & _
" <img src="rt.com-on_contact-220405-no_blurb_html_1dff87941f1c724a.jpg" name="Image1" alt="On Contact: Race and America's long war" align="bottom" width="280" height="157" border="1"/>" & @CRLF & _
" </font>" & @CRLF & _
"</a>" & @CRLF & _
"</p>" & @CRLF & _
" <p style="margin-bottom: 0in">On the show, Chris Hedges discusses" & @CRLF & _
" America's inner and outer wars and its nexus with capitalism and" & @CRLF & _
" empire with Professor of Social and Cultural Analysis and History at" & @CRLF & _
" New York University Nikhil Pal Singh. The internal violence in the" & @CRLF & _
" United... " & @CRLF & _
" </p>" & @CRLF & _
" <p style="margin-bottom: 0in">Feb 27, 2022 10:36</p>" & @CRLF & _
" <li><p style="margin-bottom: 0in"><a href="https://www.rt.com/shows/on-contact/550319-george-washington-genocidal-colonist/">" & @CRLF & _
" <font color="#000080">" & @CRLF & _
" <img src="rt.com-on_contact-220405-no_blurb_html_198feb67032166ff.png" name="Image3" alt="On Contact: George Washington and the legacy of white supremacy" align="bottom" width="280" height="157" border="1"/>" & @CRLF & _
" </font>" & @CRLF & _
"</a>" & @CRLF & _
"</p>" & @CRLF & _
" <p style="margin-bottom: 0in"><strong><a href="https://www.rt.com/shows/on-contact/550319-george-washington-genocidal-colonist/">On" & @CRLF & _
" Contact: George Washington and the legacy of white supremacy </a></strong>" & @CRLF & _
" </p>" & @CRLF & _
" <p style="margin-bottom: 0in">On the show, Chris Hedges discusses" & @CRLF & _
" George Washington, the fallible human being and one of the principal" & @CRLF & _
" architects of the United States, with author Nathaniel Philbrick. As" & @CRLF & _
" America fractures into ideologically hostile camps, it colors how" & @CRLF & _
" we... " & @CRLF & _
" </p>" & @CRLF & _
" <p style="margin-bottom: 0in">Feb 25, 2022 09:09 " & @CRLF & _
" </p>" & @CRLF & _
" <li>[...]"
Local $sSubst = "$4\t$2\t$1\t$3\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)