import re
regex = re.compile(r"(?<=/[*]{2}|(?<!\A)\G)\n\K^\s*+(?![*]/)(.*)$", flags=re.MULTILINE)
test_str = ("/**\n"
" Lorem Ipsum is simply dummy text of the printing and typesetting industry. \n"
" Lorem Ipsum has been the industry's standard dummy text ever since the \n"
" 1500s, when an unknown printer took a galley of type and scrambled it to \n"
" make a type specimen book. It has survived not only five centuries, but \n"
" also the leap into electronic typesetting, remaining essentially \n"
" unchanged. It was popularised in the 1960s with the release of Letraset \n"
" sheets containing Lorem Ipsum passages, and more recently with desktop \n"
" publishing software like Aldus PageMaker including versions of Lorem Ipsum.\n"
" */\n\n"
"[rest of code]")
subst = "/// $1"
result = regex.sub(subst, test_str)
if result:
print(result)