$re = '/(\w+(\((?R)(, ?(?R))*\))?)/mi';
$str = 'blah, foo(a,ba(x,y)), bar(c,d), yo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);