$re = '/[A-Z][0-9][a-z]/';
$str = 'A3s';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);