package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`name(?:,page\d+)?\/`)
var str = `name/
name,page1/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}