import Foundation
let pattern = #"\b\W*<hr>\W*<p>(?:<a href(?:[^<]|<[^/]|</[^a]|</a[^>])*</a>\W*){2,}</p>.?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
▼ Can't change language on Google Account ✓ ✓ (1) ×1 4 hours ago by user905392
<p>The Google Accounts home page, "My Account", is available in all languages offered by Google. You can change the display language suit your preferences. To do your research in the language of your choice, you can configure Google: Go to the home page, click on the nut on the right side of the screen, then go to search parameters</p>
<hr>
<p><a href="https://getappvalley.com/" rel="nofollow noreferrer">Appvalley</a> <a href="https://tutuapp.win/" rel="nofollow noreferrer">Tutuapp</a> <a href="https://tweakbox.mobi/" rel="nofollow noreferrer">Tweakbox</a> </p>
Potentially bad keyword in answer
▼ How do I fill out Google applications when their own reCAPTCHA is broken? ✓ ✓ ✓ ✓ ✓ (151) 2 days ago by user905392
<p>some have the same troubles as you. If you ever have the solution could you send it thanks.</p>
<hr>
<p><a href="https://dltutuapp.com/" rel="nofollow noreferrer">Tutuapp</a> <a href="https://kodi.software/" rel="nofollow noreferrer">Kodi</a> <a href="https://luckypatcher.pro/" rel="nofollow noreferrer">Lucky Patcher</a></p>
Blacklisted website in answer, Link at end of answer
▼ Can't change language on Google Account ✓ ✓ (91) 2 days ago by jowell
<p>The Google Accounts home page, "My Account", is available in all languages offered by Google. You can change the display language suit your preferences.
To do your research in the language of your choice, you can configure Google:
Go to the home page, click on the nut on the right side of the screen, then go to search parameters
<hr>
<p><a href="https://dltutuapp.com/" rel="nofollow noreferrer">https://dltutuapp.com/</a>
<a href="https://kodi.software/" rel="nofollow noreferrer">https://kodi.software/</a>
<a href="https://luckypatcher.pro/" rel="nofollow noreferrer">https://luckypatcher.pro/</a></p>
Blacklisted website in answer
▼ Joycons buzzing in Portal Knights on Nintendo Switch ✓ ✓ (152) ×1 23 days ago by seth
<p>I want to buy it because I thought the combat system will be good.</p>
<hr>
<p><a href="https://dltutuapp.com/" rel="nofollow noreferrer">https://dltutuapp.com/</a>
<a href="https://kodi.software/" rel="nofollow noreferrer">https://kodi.software/</a>
<a href="https://luckypatcher.pro/" rel="nofollow noreferrer">https://luckypatcher.pro/</a></p>
Blacklisted website in answer, Link at end of answer, Potentially bad keyword in answer
▼ How can I block ringing of incoming calls of unknown numbers? ✓ ✓ (152) a month ago by user905392
<p>I think that with your trick the unknown numbers can't call and they not appears on the call log</p>
<hr>
<p><a href="https://dltutuapp.com/" rel="nofollow noreferrer">Tutuapp</a> <a href="https://kodi.software/" rel="nofollow noreferrer">kodi</a> <a href="https://luckypatcher.pro/" rel="nofollow noreferrer">Lucky Patcher</a></p>
Blacklisted website in answer, Link at end of answer, Potentially bad keyword in answer
▼ My downloads keep freezing, what should I do? ✓ ✓ ✓ ✓ (1) a month ago by seth
<p>I too have the same problem, when I launch the app, a message appears "a problem occurred when connecting to google servers, please try again later. I do not know what to do.</p>
<hr>
<p><a href="https://getappvalley.com/" rel="nofollow noreferrer">https://getappvalley.com/</a>
<a href="https://tutuapp.win/" rel="nofollow noreferrer">https://tutuapp.win/</a>
<a href="https://tweakbox.mobi/" rel="nofollow noreferrer">https://tweakbox.mobi/</a></p>
Potentially bad keyword in answer
▼ How can Outlook automatically unsubscribe me from emails? ✓ ✓ ✓ (67) 2 months ago by avensis david
<p>To unsubscribe from unwanted emails from some senders there are 2 options</p>
<ol>
<li>The first option allows you to unsubscribe from a company's future newsletters</li>
</ol>
<p>Click on the 'Cancel subscription' button at the bottom of the page
Click on 'Cancel subscription'.</p>
<hr>
<p><a href="https://getappvalley.com/" rel="nofollow noreferrer">Appvalley</a> <a href="https://tutuapp.win/" rel="nofollow noreferrer">Tutuapp</a> <a href="https://tweakbox.mobi/" rel="nofollow noreferrer">Tweakbox</a></p>
Blacklisted user
▼ How to style window borders in Linux Mint w/ Cinnamon? ✓ ✓ (158) 2 months ago by avensis david
<p>The customization under Cinnamon is very simple. Here is how to change the appearance of windows, the addition of new icons or even pointers.
The principle must be a priori the same regardless of the graphical environment.
→ We click on usr (like user), share and finally themes.
→ From the download folder, copy the file and paste it into the themes folder.
Picture
→ With the right click of the mouse on the freshly copied file, it is extracted here.</p>
<hr>
<p><a href="https://plex.software/" rel="nofollow noreferrer">Plex</a> <a href="https://kodi.software/" rel="nofollow noreferrer">Kodi</a> <a href="https://luckypatcher.pro/" rel="nofollow noreferrer">Lucky Patcher</a> </p>
Blacklisted website in answer, Blacklisted user
▼ How can I change the public IP address? ✓ 💩 (61) ×1 2 months ago by ismart
<p>Change your IP address: is it legal?</p>
<hr>
<p><a href="https://showbox.software/" rel="nofollow noreferrer">https://showbox.software/</a>
<a href="https://kodi.software/" rel="nofollow noreferrer">https://kodi.software/</a>
<a href="https://luckypatcher.pro/" rel="nofollow noreferrer">https://luckypatcher.pro/</a></p>
Link at end of answer, Potentially bad keyword in answer
▼ How to style window borders in Linux Mint w/ Cinnamon? ✓ ✓ (1) ×4 2 months ago by avensis david
<p>The customization under Cinnamon is very simple. Here is how to change the appearance of windows, the addition of new icons or even pointers.
→ We click on usr (like user), share and finally themes.
→ From the download folder, copy the file and paste it into the themes folder.
Picture
→ With the right click of the mouse on the freshly copied file, it is extracted here.</p>
<hr>
<p><a href="https://showbox.software/" rel="nofollow noreferrer">https://showbox.software/</a>
<a href="https://kodi.software/" rel="nofollow noreferrer">https://kodi.software/</a>
<a href="https://luckypatcher.pro/" rel="nofollow noreferrer">https://luckypatcher.pro/</a></p>
Potentially bad keyword in answer
▼ MongoDB: Replica Set - master vs. slave ✓ ✓ ✓ (60) 5 months ago by user182115
<p>At startup, the databases will negotiate which is master and which is slave. Upon an outage of one database server, the other will automatically take over and become master from that point on.</p>
<hr>
<p><a href="https://kodi.software/" rel="nofollow noreferrer">Kodi</a> <a href="https://luckypatcher.pro/" rel="nofollow noreferrer">Lucky Patcher</a></p>
Link at end of answer
▼ Woocommerce Attribute kept loading in adminpanel ✓ ✓ ✓ ✓ (110) 9 months ago by JustOutblog
<p>I had the same problem, it was solved after updating all plugins , i did not disable any plugin.</p>
<hr>
<p><a href="http://www.justoutblog.com" rel="nofollow noreferrer">JustOutblog</a> |
<a href="http://www.shopnship.co" rel="nofollow noreferrer">Shopnship.co</a></p>
Link at end of answer, Username similar to website in answer
▼ Can't start apache in XAMPP ✓ ✓ (139) a year ago by hajir.roshani
<p>just disable skype and vmware</p>
<hr>
<p><a href="http://controlmakers.ir/en/" rel="nofollow noreferrer">Controlmakers</a>
<a href="http://infu.ir/" rel="nofollow noreferrer">Infu</a></p>
Link at end of answer, Pattern-matching website in answer
▼ Android: How to distinguish CLEAR all events from notification bar from user action ✗ ✓ (94) 2 years ago by ChungCB126
<p>If your code is navigating the user back to the app when the notification is cleared, then you already have a problem with your design. If the user clears your notification you should NOT be trying to navigate them back. Hence the setDeleteIntent() should NOT be associated with starting any activity.</p>
<hr>
<p><a href="https://www.dktmedia.vn" rel="nofollow"> Qu?ng cáo tr?c tuy?n</a>| <a href="https://www.dktmedia.vn/quang-cao-facebook.html" rel="nofollow"> Qu?ng cáo Facebook</a></p>
Manually reported answer
▼ Getting Window function to assign variable locally ✓ ✓ (77) 2 years ago by ChungCB126
<p>I have the same problem. Who can answer the question?!?</p>
<hr>
<p><a href="https://www.dktmedia.vn" rel="nofollow"> Qu?ng cáo tr?c tuy?n</a> | <a href="https://www.dktmedia.vn/quang-cao-google.html" rel="nofollow"> Qu?ng cáo Google</a></p>
Non-english link in answer
▼ Form get to pretty link ✓ ✓ (94) 2 years ago by Sandangku OnlineShop
<p>You can change it.
and you can find .htaccess.
I will ask again to my friend.</p>
<hr>
<p><a href="http://www.sandangku.com/" rel="nofollow">Kaos Murah</a> <a href="http://www.sandangku.com/" rel="nofollow">Kaos Distro</a></p>
Manually reported answer
▼ print unique numbers from a sorted list python ✓ ✓ (127) 2 years ago by Sandangku OnlineShop
<p>Maybe I will can try it.
And the result of progress i will be coment there.
Wait me. Thank you.</p>
<hr>
<p><a href="http://www.sandangku.com/" rel="nofollow">Kaos Murah</a> <a href="http://www.sandangku.com/" rel="nofollow">Desain Kaos</a></p>
Link at end of answer, Blacklisted user
▼ Form get to pretty link ✓ ✓ (60) 2 years ago by Sandangku OnlineShop
<p>You can change it.
and you can find .htaccess.
I will ask again to my friend.</p>
<hr>
<p><a href="http://www.sandangku.com/" rel="nofollow">Kaos Murah</a> <a href="http://www.sandangku.com/" rel="nofollow">Kaos Distro</a></p>
Link at end of answer
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)