using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<TestName>.*)EXP=(?P<EXP>\s*(?P<EXPvalue>-?\s*\d+\.?\d*)\s*(\+/-)?(?P<Limits>\s*-?\s*\d+.?\d*)?\s*(?P<EXPunits>.*))ACT=(?P<ACT>\s*(?P<ACTvalue>-?\s*\d+\.?\d*)\s*(?P<ACTunits>.*))RES=(?P<RES>.*)SN:(?P<SN>.*) ";
string input = @"QTMU 0, Serial Number: 1494
6A EVENT COUNT POS edge EXP= 512 counts ACT= 512 RES=TMU0 SN: 1494
6A EVENT COUNT NEG edge EXP= 512 counts ACT= 512 RES=TMU0 SN: 1494
6A EVENT COUNT
2A -115V thru Mux to IADC EXP=-2.79940 +/-0.315mV ACT=-2.84159 V RES=SPU 13 SN: 3609
4I ADC2 FORCED OVER RANGE EXP= 0001 ACT= 0001 RES=QMS4 /16-0 SN: 674
4I ADC2 BIT TEST EXP= 0fff ACT= 0fff RES=QMS4 /16-0 SN: 674
9D ADC, GND EXP= 0.00000 +/-20.00mV ACT= 1.53825mV RES=APU12 28 SN: 3789";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}