re = /(?:^|,)\s*\K(?=[^,]*[^\s,])[^,]+?(?=\s*(?:,|$))/
str = ' Monday,Tuesday, Wednesday ,Hello World , Lorem ipsum dolor sit amet , , a b c d e '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end