re = /:-.*?-:\W*(*SKIP)(*F)|(?:(?:http|ftp|https):\/\/)?[\w-]+(?:\.[\w-]+)+([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?/
str = ':-:casperon.png:-: google.com www.yahoo.com :-:sample.jpg:-: http://stackoverflow.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end