import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Your BANK a\\/c xxxx (\\d{4}) will be debited for Rs ([\\d|,]+\\.*\\d+) towards HDFCBank CreditCard payment on (\\d{2}\\/\\w{3}\\/\\d{4}) .";
final String string = "Your BANK a/c xxxx 4114 will be debited for Rs 97856.5 towards HDFCBank CreditCard payment on 22/FEB/2016 .";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}