const regex = /(?<=\[)(?<inside_value>[^\][]*(?:\[[^\][]*][^\][]*)?)(?=])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\[)(?<inside_value>[^\\][]*(?:\\[[^\\][]*][^\\][]*)?)(?=])', 'gm')
const str = `A) [ClusterReceiver[99] ]
B) [first-second-third-8050-exec-a ]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}