import Foundation
let pattern = #".*<a\shref="http:\/\/(.*)">.*<\/a>.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<h2><a href="http://www.google.com/test">Link</a></h2>2014-54-22 22:23"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)