const regex = /^(\S+\s?)+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S+\\s?)+$', 'gmi')
const str = `a b cde f ghijk lm n
but reject
a b cd ef g
x y z y`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}