re = /^(.)\1+$/m
str = 'aaaaaaaaaaaaaa
bbbbbbbbbbbbbb
aaaaaaaaaadaaaaaaa
daaaaaaaaaaaaaaaaaa
rrrrrrrrrrrrrrr
ffffffeeeeeffffff
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end