import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Error>((?:.*?\\n?)+.*?)<\\/Error>";
final String string = "<Error>\n"
+ " <ErrorId>AllConditionsTrue</ErrorId>\n"
+ " <MetaData>\n"
+ " <Entry>\n"
+ " <Key>Balance Due</Key>\n"
+ " <Value>1500.99</Value>\n"
+ " </Entry>\n"
+ " </MetaData>\n"
+ "</Error>\n\n"
+ "<Error>\n"
+ " <ErrorId>Opposite</ErrorId>\n"
+ " <MetaData>\n"
+ " <Entry>\n"
+ " <Key>Node</Key>\n"
+ " </Entry>\n"
+ " </MetaData>\n"
+ "</Error>\n\n"
+ "<Error>\n"
+ " <ErrorId>minInclusive</ErrorId>\n"
+ " <MetaData>\n"
+ " <Entry>\n"
+ " <Key>Description</Key>\n"
+ " <Value>Wages Amount</Value>\n"
+ " </Entry>\n"
+ " </MetaData>\n"
+ "</Error>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}