import re
regex = re.compile(r"^1?$|^(11+?)\1+$", flags=re.MULTILINE)
test_str = ("\n"
"1\n"
"11\n"
"111\n"
"1111\n"
"11111\n"
"111111\n"
"1111111\n"
"11111111\n"
"111111111\n"
"1111111111\n"
"11111111111\n"
"111111111111\n"
"1111111111111")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")