use strict;
my $str = '\'\'something\'\'';
my $regex = qr/''(.*?'')/p;
my $subst = '``$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";