re = /^Bearer ((?:\.?(?:[A-Za-z0-9-_]+)){3})$/m
str = 'Bearer eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJzdWIiOiIxMjM0NTY3ODkwIiwibmFtZSI6IkpvaG4gRG9lIiwiaWF0IjoxNTE2MjM5MDIyfQ.SflKxwRJSMeKKF2QT4fwpMeJf36POk6yJV_adQssw5c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end